Add dependency to alexa-viewer, launcher, homescreen, cluster-receiver
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
1 SUMMARY     = "Home Screen application"
2 DESCRIPTION = "AGL demonstration Home Screen application"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     qtbase \
10     qtdeclarative \
11     qtquickcontrols2 \
12     libqtappfw \
13     libhomescreen \
14     libafb-helpers-qt \
15     wayland-native \
16     wayland \
17     qtwayland \
18     qtwayland-native \
19 "
20
21 # FIXME: homescreen needs agl-shell-desktop, part of agl-compositor(-protocols) package
22 DEPENDS_append = " agl-compositor"
23
24 PV      = "1.0+git${SRCPV}"
25
26 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
27 SRCREV  = "${AGL_APP_REVISION}"
28
29 S       = "${WORKDIR}/git"
30
31 inherit qmake5 systemd pkgconfig aglwgt
32
33 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
34
35 OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
36
37 RDEPENDS_${PN} += " \
38     libqtappfw \
39     agl-service-audiomixer \
40     agl-service-bluetooth \
41     agl-service-homescreen \
42     agl-service-network \
43     agl-service-weather \
44     agl-service-voice-high \
45 "