homescreen: update recipe
[AGL/meta-agl-demo.git] / recipes-demo / homescreen / homescreen_git.bb
1 SUMMARY     = "Home Screen application"
2 DESCRIPTION = "AGL demonstration Home Screen application"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     qtbase \
10     qtdeclarative \
11     qtquickcontrols2 \
12     wayland-native \
13     wayland \
14     qtwayland \
15     qtwayland-native \
16     agl-compositor \
17 "
18
19 PV = "1.0+git${SRCPV}"
20
21 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH} \
22            file://homescreen.service \
23 "
24 SRCREV = "${AGL_APP_REVISION}"
25
26 S = "${WORKDIR}/git"
27
28 inherit qmake5 systemd pkgconfig
29
30 PATH:prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
31
32 OE_QMAKE_CXXFLAGS:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
33
34 do_install:append() {
35     install -D -p -m0644 ${WORKDIR}/homescreen.service ${D}${systemd_system_unitdir}/homescreen.service
36 }
37
38 SYSTEMD_SERVICE_${PN} = "homescreen.service"
39 SYSTEMD_AUTO_ENABLE = "enable"
40
41 RDEPENDS:${PN} += " \
42     qtwayland \
43     qtbase-qmlplugins \
44     qtgraphicaleffects-qmlplugins \
45 "