71d988dbb011f4fa794d7320487f101349cea900
[AGL/meta-agl-demo.git] / recipes-demo / flutter-dashboard / flutter-app-dashboard_git.bb
1 SUMMARY = "Flutter Dashboard"
2 DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
3
4 HOMEPAGE = "https://github.com/hritik-chouhan/dashboard_for_recipe"
5
6 BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
7
8 SECTION = "graphics"
9
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
12
13
14 SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main \
15     file://dashboard_config.yaml \
16     "
17
18 SRCREV = "5b0e5cdc3ba8b00a7e53b46e8b3e656cd09822bb"
19 S = "${WORKDIR}/git"
20
21
22 inherit agl-app flutter-app
23
24 # flutter-app
25 #############
26 PUBSPEC_APPNAME = "dashboard_app"
27 FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
28 FLUTTER_BUILD_ARGS = "bundle -v"
29
30 # agl-app
31 #########
32 AGL_APP_TEMPLATE = "agl-app-flutter"
33 AGL_APP_ID = "dashboard_app"
34 AGL_APP_NAME = "Flutter Dashboard"
35
36
37
38 do_install:append() {
39     install -d ${D}${sysconfdir}/xdg/AGL
40     install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
41
42
43     
44 }
45
46 FILES:${PN} += "${sysconfdir}/xdg/AGL"
47