b2a4640736baad826fc7cd9d8b5d69cbf5110cc0
[AGL/meta-agl-demo.git] / recipes-demo / cluster-receiver / cluster-receiver_git.bb
1 SUMMARY     = "Instrument Cluster Receiver application"
2 DESCRIPTION = "AGL demonstration instrument cluster remote display application"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-receiver"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0 & MIT"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=374fee6a7817f1e1a5a7bfb7b7989553"
8
9 DEPENDS = " \
10     wayland wayland-native \
11     gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad \
12 "
13
14 # FIXME: cluster-receiver needs agl-shell-desktop, part of agl-compositor(-protocols) package
15 DEPENDS_append = " agl-compositor"
16
17 PV = "1.0+git${SRCPV}"
18
19 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-cluster-demo-receiver;protocol=https;branch=${AGL_BRANCH}"
20 SRCREV  = "${AGL_APP_REVISION}"
21
22 S  = "${WORKDIR}/git"
23
24 inherit cmake pkgconfig aglwgt
25
26 RDEPENDS_${PN} += " \
27     gstreamer1.0-plugins-base \
28     gstreamer1.0-plugins-good \
29     gstreamer1.0-plugins-bad \
30 "