70542ff4d08961ec855d87c3fa51e5d59c584b7b
[AGL/meta-agl-demo.git] / recipes-demo / alexa-viewer / alexa-viewer_git.bb
1 SUMMARY     = "Demo voice capabilities template viewer for Alexa voiceagent"
2 DESCRIPTION = "Demo voice capabilities template viewer for Alexa voiceagent"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/alexa-viewer"
4 SECTION     = "apps"
5
6 LICENSE     = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
8
9 DEPENDS = " \
10     qtquickcontrols2 \
11     qlibhomescreen \
12     af-binder \
13     libqtappfw \
14     wayland-native \
15     wayland \
16     qtwayland \
17     qtwayland-native \
18 "
19
20 # FIXME: alexa-viewer needs agl-shell-desktop, part of agl-compositor(-protocols) package
21 DEPENDS_append = " agl-compositor"
22
23 PV = "1.0+git${SRCPV}"
24
25 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/alexa-viewer;protocol=https;branch=${AGL_BRANCH}"
26 SRCREV  = "${AGL_APP_REVISION}"
27
28 S  = "${WORKDIR}/git"
29
30 inherit cmake_qt5 aglwgt
31
32 OECMAKE_CXX_FLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
33
34 RDEPENDS_${PN} = " \
35     libqtappfw \
36     libafbwsc \
37     qlibhomescreen \
38     agl-service-homescreen \
39     agl-service-voice-high-capabilities \
40 "