Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-demo / agl-vss-helper / agl-vss-helper.bb
1 DESCRIPTION = "AGL VSS helper daemon"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://agl-vss-helper.py \
6            file://agl-vss-helper.yaml \
7            file://agl-vss-helper.token \
8            file://agl-vss-helper.service \
9 "
10
11 S = "${WORKDIR}/sources"
12 UNPACKDIR = "${S}"
13
14 inherit systemd
15
16 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
17
18 do_configure[noexec] = "1"
19 do_compile[noexec] = "1"
20
21 do_install() {
22     install -d ${D}${sbindir}
23     install -m 0755 ${UNPACKDIR}/${BPN}.py ${D}${sbindir}
24     install -d ${D}${sysconfdir}/xdg/AGL/${BPN}
25     install -m 0644 ${UNPACKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
26     install -m 0644 ${UNPACKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
27     install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
28 }
29
30 RDEPENDS:${PN} = " \
31     python3 \
32     python3-asyncio \
33     python3-systemd \
34     kuksa-databroker \
35     kuksa-databroker-agl \
36     kuksa-client \
37     kuksa-certificates-agl-ca \
38 "