Update cluster network configuration
[AGL/meta-agl-demo.git] / recipes-demo / agl-service-hvac / agl-service-hvac-demo-conf.bb
1 SUMMARY     = "AGL demo configuration for HVAC service daemon"
2 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
3 SECTION     = "apps"
4
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8 SRC_URI = "file://agl-service-hvac-can.conf.demo \
9            file://sllin.conf \
10 "
11
12 PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14 do_configure[noexec] = "1"
15 do_compile[noexec] = "1"
16
17 do_install () {
18     # Install configuration file to use sllin0 instead of the default
19     # can0 CAN device.
20     install -D -m 644 ${WORKDIR}/agl-service-hvac-can.conf.demo ${D}${sysconfdir}/xdg/AGL/agl-service-hvac-can.conf
21
22     # Install systemd override to add a dependency on kuksa-dbc-feeder-sllin.service,
23     # which currently brings up sllin0.  This will need to be reworked in the future
24     # to be a bit more straightforward.
25     install -d ${D}${systemd_system_unitdir}/agl-service-hvac.service.d
26     install -m 0644 ${WORKDIR}/sllin.conf ${D}${systemd_system_unitdir}/agl-service-hvac.service.d/
27 }
28
29 FILES:${PN} += "${systemd_system_unitdir}"
30
31 RDEPENDS:${PN} += "agl-service-hvac kuksa-dbc-feeder-sllin"