agl-ivi-demo-html5: remove duplicated include
[AGL/meta-agl-demo.git] / recipes-demo / agl-service-audiomixer / agl-service-audiomixer_git.bb
1 SUMMARY     = "Audio Mixer Service Daemon"
2 DESCRIPTION = "AGL Audio Mixer Service Daemon"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-audiomixer"
4 SECTION     = "apps"
5 LICENSE     = "MIT & Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
7
8 DEPENDS = " \
9     glib-2.0 \
10     boost \
11     openssl \
12     systemd \
13     pipewire \
14     wireplumber \
15     protobuf-native \
16     grpc-native \
17     protobuf \
18     grpc \
19     kuksa-databroker \
20 "
21
22 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-audiomixer.git;protocol=https;branch=${AGL_BRANCH} \
23            file://agl-service-audiomixer.conf.default \
24            file://agl-service-audiomixer.conf.gateway-demo \
25            file://agl-service-audiomixer.token \
26 "
27 SRCREV  = "0ff3ef1b254364639fc42495bbcfb4760250990a"
28
29 PV = "2.0+git${SRCPV}"
30 S  = "${WORKDIR}/git"
31
32 inherit meson pkgconfig systemd update-alternatives
33
34 EXTRA_OEMESON += "-Dprotos=${STAGING_INCDIR}"
35
36 SYSTEMD_SERVICE:${PN} = "agl-service-audiomixer.service" 
37
38 do_install:append() {
39     # Currently using default global client and CA certificates
40     # for KUKSA.val SSL, installing app specific ones would go here.
41
42     # VIS authorization token file for KUKSA.val should ideally not
43     # be readable by other users, but currently that's not doable
44     # until a packaging/sandboxing/MAC scheme is (re)implemented or
45     # something like OAuth is plumbed in as an alternative.
46     install -d ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer
47     install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.default ${D}${sysconfdir}/xdg/AGL/
48     install -m 0644 ${WORKDIR}/agl-service-audiomixer.conf.gateway-demo ${D}${sysconfdir}/xdg/AGL/
49     install -m 0644 ${WORKDIR}/agl-service-audiomixer.token ${D}${sysconfdir}/xdg/AGL/agl-service-audiomixer/
50 }
51
52 FILES:${PN} += "${systemd_system_unitdir}"
53
54 RDEPENDS:${PN} += "${PN}-conf"
55
56 ALTERNATIVE_LINK_NAME[agl-service-audiomixer.conf] = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf"
57
58 PACKAGE_BEFORE_PN += "${PN}-conf ${PN}-conf-gateway-demo"
59
60 FILES:${PN}-conf += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
61 RDEPENDS:${PN}-conf = "${PN}"
62 RPROVIDES:${PN}-conf = "agl-service-audiomixer.conf"
63 ALTERNATIVE:${PN}-conf = "agl-service-audiomixer.conf"
64 ALTERNATIVE_TARGET_${PN}-conf = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.default"
65
66 FILES:${PN}-conf-gateway-demo += "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
67 RDEPENDS:${PN}-conf-gateway-demo = "${PN}"
68 RPROVIDES:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
69 ALTERNATIVE:${PN}-conf-gateway-demo = "agl-service-audiomixer.conf"
70 ALTERNATIVE_TARGET_${PN}-conf-gateway-demo = "${sysconfdir}/xdg/AGL/agl-service-audiomixer.conf.gateway-demo"
71 ALTERNATIVE_PRIORITY_${PN}-conf-gateway-demo = "20"