84cb34edcee41f743e5d813090d3943816ee4b90
[AGL/meta-agl-demo.git] / recipes-core / nss / nss-agl-driver-db_git.bb
1 SUMMARY = "Custom nss db hosting the kuksa certificates"
2 DESCRIPTION = "Custom nss db hosting the kuksa certificates for chromium"
3 AUTHOR = "Jan-Simon Moeller <jsmoeller@linuxfoundation.org>"
4 HOMEPAGE = "https://git.automotivelinux.org"
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
7
8 PV = "0.1"
9
10 SRC_URI = "file://${BPN}.service \
11            file://${BPN}.sh \
12           "
13
14 S = "${WORKDIR}/sources"
15 UNPACKDIR = "${S}"
16
17 inherit systemd
18
19 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
20
21 do_configure[noexec] = "1"
22 do_compile[noexec] = "1"
23
24 do_install() {
25     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
26         install -d ${D}${systemd_system_unitdir}
27         install -d ${D}${sbindir}
28         install -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}
29         install -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}
30     fi
31 }
32
33 FILES:${PN} += "${systemd_system_unitdir} ${sbindir}"
34
35 RDEPENDS:${PN} += "nss agl-users kuksa-val-certificates-client bash"