Add persistent storage grpc API
[AGL/meta-agl-demo.git] / recipes-connectivity / vss / vss-tools_4.2.bb
1 SUMMARY = "COVESA Vehicle Signal Specification tooling."
2 HOMEPAGE = "https://github.com/COVESA/vss-tools"
3 LICENSE = "MPL-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
5
6 SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=release/4.2"
7 SRCREV = "b350788d6dd16942e987fdb9e8b8b3b403fe23c6"
8
9 S = "${WORKDIR}/git"
10
11 inherit setuptools3
12
13 RDEPENDS:${PN} += " \
14     python3-core \
15     python3-ctypes \
16     python3-email \
17     python3-importlib-metadata \
18     python3-json \
19     python3-logging \
20     python3-netclient \
21     python3-pkg-resources \
22     python3-anytree \
23     python3-deprecation \
24     python3-graphql-core \
25     python3-pyyaml \
26     python3-six \
27 "
28
29 BBCLASSEXTEND += "native nativesdk"