kuksa-viss-client: add Python 3.10 support patch
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-viss-client_git.bb
1 SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
2 HOMEPAGE = "https://github.com/eclipse/kuksa.val"
3 BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
4
5 LICENSE = "EPL-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
7
8 DEPENDS = "python3-setuptools-git-versioning-native"
9
10 require kuksa-val.inc
11
12 SRC_URI += "file://0001-Update-kuksa-viss-client-to-support-Python-3.10.patch"
13
14 inherit setuptools3
15
16 RDEPENDS:${PN} += " \
17     python3-cmd2 \
18     python3-importlib-metadata \
19     python3-pkg-resources \
20     python3-pygments \
21     python3-websockets \
22 "
23
24 # A script for generating new certificates currently gets shipped inside
25 # the client module, for now add bash to RDEPENDS to quiet the QA error.
26 # This should probably be addressed with finer-grained packaging or some
27 # other change worked out with upstream.
28 RDEPENDS:${PN} += "bash"