3a33e0331b37c6f82089a1c470dae9ada95cd83e
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / kuksa-viss-client_git.bb
1 SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
2 HOMEPAGE = "https://github.com/eclipse/kuksa.val"
3 BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"
4
5 LICENSE = "EPL-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
7
8 DEPENDS = "python3-setuptools-git-versioning-native"
9
10 require kuksa-val.inc
11
12 inherit setuptools3
13
14 RDEPENDS:${PN} += " \
15     python3-cmd2 \
16     python3-importlib-metadata \
17     python3-pkg-resources \
18     python3-pygments \
19     python3-websockets \
20 "
21
22 # A script for generating new certificates currently gets shipped inside
23 # the client module, for now add bash to RDEPENDS to quiet the QA error.
24 # This should probably be addressed with finer-grained packaging or some
25 # other change worked out with upstream.
26 RDEPENDS:${PN} += "bash"