Update recipes for transition to UNPACKDIR
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / can-dev-helper_1.0.bb
1 SUMMARY = "Systemd unit for CAN device helper"
2 LICENSE = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://can-dev-helper.service \
6            file://can-dev-helper.sh \
7 "
8
9 S = "${WORKDIR}/sources"
10 UNPACKDIR = "${S}"
11
12 inherit systemd allarch
13
14 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
15
16 do_configure[noexec] = "1"
17 do_compile[noexec] = "1"
18
19 do_install() {
20     install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
21     install -D -m 0755 ${UNPACKDIR}/${BPN}.sh ${D}${sbindir}/${BPN}.sh
22 }
23
24 FILES:${PN} += "${systemd_system_unitdir}"
25
26 RDEPENDS:${PN} += "bash"