agl-dbc: Add recipe
[AGL/meta-agl-demo.git] / recipes-connectivity / kuksa-val / agl-dbc_git.bb
1 SUMMARY = "CAN database (DBC) files for AGL demos"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=f814e94ea4f54c1cdeb3fa60579ca000"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-dbc;protocol=https;branch=${AGL_BRANCH}"
6 SRCREV  = "e215d8663370fcdb477d1bc20b434b7e4295fab7"
7
8 PV = "1.0+git${SRCPV}"
9 S  = "${WORKDIR}/git"
10
11 inherit allarch
12
13 do_configure[noexec] = "1"
14 do_compile[noexec] = "1"
15
16 do_install() {
17     install -d ${D}${datadir}/dbc
18     install -m 0644 ${S}/agl-vcar.dbc ${D}${datadir}/dbc/
19 }
20
21 FILES:${PN} += "${datadir}/dbc"