Use latest version of conf.d/templates submodule.
[apps/agl-service-unicens.git] / packaging / unicens-agent.spec
1 ###########################################################################
2 # Copyright 2015, 2016, 2017 IoT.bzh
3 #
4 # author: Fulup Ar Foll <fulup@iot.bzh>
5 #
6 # Licensed under the Apache License, Version 2.0 (the "License");
7 # you may not use this file except in compliance with the License.
8 # You may obtain a copy of the License at
9 #
10 #     http://www.apache.org/licenses/LICENSE-2.0
11 #
12 # Unless required by applicable law or agreed to in writing, software
13 # distributed under the License is distributed on an "AS IS" BASIS,
14 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
15 # See the License for the specific language governing permissions and
16 # limitations under the License.
17 ###########################################################################
18
19
20 Name:    unicens-agent
21 Version: 0.1
22 Release: 1
23 License: Apache-V2
24 Summary: Expose MicroChip UnicensV2 through AGL AppFw
25 Url:     https://github.com/iotbzh/unicens-agent
26 Source0: %{name}_%{version}.orig.tar.gz
27
28 Prefix: /opt/unicens-agent
29 BuildRequires: cmake
30 BuildRequires: gcc gcc-c++
31 BuildRequires: pkgconfig(libsystemd) >= 222,
32 BuildRequires: pkgconfig(libmicrohttpd) >= 0.9.54
33 BuildRequires: pkgconfig(afb-daemon), pkgconfig(json-c), pkgconfig(mxml)
34
35 BuildRoot:%{_tmppath}/%{name}-%{version}-build
36
37 %description 
38 Expose MicroChip UnicensV2 through AGL AppFw
39
40 %prep
41 %setup -q
42
43 %build
44 %cmake -DBINDINGS_INSTALL_PREFIX:PATH=%{_libdir}
45 %__make %{?_smp_mflags}
46
47 %install
48 [ -d build ] && cd build
49 %make_install
50
51 %files
52 %defattr(-,root,root)
53 %dir %{_libdir}/unicens-agent
54 %{_libdir}/unicens-agent/afb-ucs2.so