Widget packaging rework
[AGL/meta-agl-devel.git] / meta-speech-framework / meta-aac / recipes-platform / packagegroups / packagegroup-agl-voiceagent-alexa.bb
1 SUMMARY = "The software for the AGL Alexa voiceagent feature"
2 DESCRIPTION = "The software for the AGL Alexa voiceagent feature"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 ALLOW_EMPTY_${PN} = "1"
9
10 PROVIDES = "${PACKAGES}"
11 PACKAGES = "\
12     packagegroup-agl-voiceagent-alexa \
13     packagegroup-agl-voiceagent-alexa-test \
14     packagegroup-agl-voiceagent-alexa-devel \
15     "
16
17 RDEPENDS_${PN} = " \
18     alexa-voiceagent-service \
19     "
20
21 # Empty for now, no test/dbg/coverage widgets
22 RDEPENDS_${PN}-test = ""
23 RDEPENDS_${PN}-devel = ""