ec7a1e9d593233bc938ce7d10b5192c5d9c36f21
[AGL/meta-agl-devel.git] / meta-speech-framework / meta-aac / recipes-apis / alexa-voiceagent-service / alexa-voiceagent-service_git.bb
1 SUMMARY = "Alexa voice agent binding"
2 DESCRIPTION = "alexa-voiceagent-service is an Alexa Auto SDK based voiceagent binding"
3 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
4 SECTION = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9 DEPENDS = " \
10         libafb-helpers \
11         libappcontroller \
12         avs-device-sdk \
13         aac-module-core \
14         aac-module-alexa \
15         aac-module-cbl \
16         aac-module-contact-uploader \
17         aac-module-navigation \
18         aac-module-phone-control \
19         aac-module-gstreamer \
20 "
21
22 SRC_URI = "git://github.com/alexa/alexa-auto-sdk.git;protocol=https;branch=2.0 \
23            file://0001-remove-library-dependency-copying.patch \
24 "
25 SRCREV = "86916d2d8c1702a8be3c88a9012ca56583bcc0c8"
26
27 PV = "2.0+git${SRCPV}"
28 S = "${WORKDIR}/git/platforms/agl/alexa-voiceagent-service"
29
30 inherit cmake aglwgt
31
32 EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
33
34 # NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
35 #       core module
36 RDEPENDS_${PN} += "libcurl libopus libsqlite3"
37
38 RPROVIDES_${PN} += "virtual/voiceagent"