c08377cd45a33b95a9f4b027d9af5d0d3a90d6b2
[AGL/meta-agl-devel.git] / meta-speech-framework / meta-aac / recipes-apis / alexa-voiceagent-service / alexa-voiceagent-service_git.bb
1 SUMMARY = "Alexa voice agent binding"
2 DESCRIPTION = "alexa-voiceagent-service is an Alexa Auto SDK based voiceagent binding"
3 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high"
4 SECTION = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://License.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9 DEPENDS = " \
10         libafb-helpers \
11         libappcontroller \
12         avs-device-sdk \
13         aac-module-core \
14         aac-module-alexa \
15         aac-module-address-book \
16         aac-module-car-control \
17         aac-module-cbl \
18         aac-module-contact-uploader \
19         aac-module-navigation \
20         aac-module-phone-control \
21         aac-module-system-audio \
22         ${@bb.utils.contains("ALEXA_WAKEWORD", "true", "aac-module-amazonlite pryon-lite", "", d)} \
23 "
24
25 SRC_URI = "git://github.com/alexa/alexa-auto-sdk.git;protocol=https;branch=2.3 \
26            file://alexa.json \
27            file://0001-remove-library-dependency-copying.patch \
28            file://0007-add-autobuild-scripts.patch \
29 "
30 SRCREV = "d46f22b453f528868b483e39bc7a057ca68a5199"
31
32 PV = "2.3+git${SRCPV}"
33 S = "${WORKDIR}/git/platforms/agl/alexa-voiceagent-service"
34
35 inherit cmake aglwgt
36
37 EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
38
39 ALEXA_WAKEWORD ??= "false"
40
41 do_install:append() {
42     install -D -m 0644 ${WORKDIR}/alexa.json ${D}${sysconfdir}/xdg/AGL/voiceagents/alexa.json
43 }
44
45 PACKAGES =+ "${PN}-conf"
46
47 FILES:${PN}-conf = "${sysconfdir}/xdg/AGL/voiceagents/*"
48
49 # NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
50 #       core module
51 RDEPENDS:${PN} += " \
52         libcurl \
53         libopus \
54         libsqlite3 \
55         ${PN}-conf \
56         ${@bb.utils.contains("ALEXA_WAKEWORD", "true", "pryon-lite", "", d)} \
57         gstreamer1.0-plugins-bad-hls \
58 "