Follow-up change to change of LICENSE file
[AGL/meta-agl-devel.git] / meta-speech-framework / meta-aac / recipes-apis / alexa-voiceagent-service / alexa-voiceagent-config_1.0.bb
1 SUMMARY = "Alexa service binding default configuration to connect to Alexa"
2 DESCRIPTION = "Alexa alexa-voiceagent-service binding configuration files"
3 HOMEPAGE = "https://github.com/alexa/alexa-auto-sdk/tree/master/platforms/agl/alexa-voiceagent-service"
4 SECTION = "apps"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9 SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
10
11 inherit allarch
12
13 ALEXA_WAKEWORD ??= "false"
14
15 do_compile () {
16
17     if test x"${ALEXA_CLIENTID}" == x"" ; then
18         bbfatal "ALEXA CLIENTID not defined in your environment e.g. conf/local.conf"
19     fi
20
21     if test x"${ALEXA_SERIALNUMBER}" == x"" ; then
22         bbfatal "ALEXA SERIALNUMBER not defined in your environment e.g. conf/local.conf"
23     fi
24
25     if test x"${ALEXA_PRODUCTID}" == x"" ; then
26         bbfatal "ALEXA PRODUCTID not defined in your environment e.g. conf/local.conf"
27     fi
28
29 }
30
31 do_install () {
32     #replace
33     sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" -e "s/@@WAKEWORD@@/${ALEXA_WAKEWORD}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
34
35     # install
36     install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json
37 }
38
39 RPROVIDES_${PN} += "virtual/alexa-voiceagent-config"
40