Integrate parts of meta-intel-iot-security
[AGL/meta-agl.git] / meta-security / recipes-test / udp-smack-test / udp-smack-test.bb
1 SUMMARY = "Binary used to test smack udp sockets"
2 DESCRIPTION = "Server and client binaries used to test smack attributes on UDP sockets"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SRC_URI = "file://udp_server.c \
7            file://udp_client.c \
8
9
10 S = "${WORKDIR}"
11 do_compile() {
12     ${CC} udp_client.c ${LDFLAGS} -o udp_client
13     ${CC} udp_server.c ${LDFLAGS} -o udp_server
14 }
15
16 do_install() {
17     install -d ${D}${bindir}
18     install -m 0755 udp_server ${D}${bindir}
19     install -m 0755 udp_client ${D}${bindir}
20 }