Integrate parts of meta-intel-iot-security
[AGL/meta-agl.git] / meta-security / recipes-test / tcp-smack-test / tcp-smack-test.bb
1 SUMMARY = "Binary used to test smack tcp sockets"
2 DESCRIPTION = "Server and client binaries used to test smack attributes on TCP sockets"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SRC_URI = "file://tcp_server.c \
7            file://tcp_client.c \
8
9
10 S = "${WORKDIR}"
11 do_compile() {
12     ${CC} tcp_client.c ${LDFLAGS} -o tcp_client
13     ${CC} tcp_server.c ${LDFLAGS} -o tcp_server
14 }
15
16 do_install() {
17     install -d ${D}${bindir}
18     install -m 0755 tcp_server ${D}${bindir}
19     install -m 0755 tcp_client ${D}${bindir}
20 }