Integrate parts of meta-intel-iot-security
[AGL/meta-agl.git] / meta-security / recipes-test / mmap-smack-test / mmap-smack-test.bb
1 SUMMARY = "Mmap binary used to test smack mmap attribute"
2 DESCRIPTION = "Mmap binary used to test smack mmap attribute"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6 SRC_URI = "file://mmap.c" 
7
8 S = "${WORKDIR}"
9 do_compile() {
10     ${CC} mmap.c ${LDFLAGS} -o mmap_test
11 }
12
13 do_install() {
14     install -d ${D}${bindir}
15     install -m 0755 mmap_test ${D}${bindir}
16 }