aa6d5fa6f8306fc5da32dda80cb4fd0061f508da
[AGL/meta-agl.git] / meta-security / recipes-security / smack / smack-userspace_git.bb
1 DESCRIPTION = "Selection of tools for developers working with Smack"
2 HOMEPAGE = "https://github.com/smack-team/smack"
3 SECTION = "Security/Access Control"
4 LICENSE = "LGPL-2.1"
5
6 # Alias needed to satisfy dependencies in other recipes.
7 # This recipe itself cannot be named "smack" because that
8 # would conflict with the "smack" override.
9 PROVIDES = "smack"
10 RPROVIDES_${PN} += "smack"
11
12 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
13 PV = "1.2.0+git${SRCPV}"
14 SRCREV = "d82bac7dac69823fd40015dffad1a128505a2258"
15 SRC_URI += "git://github.com/smack-team/smack.git;protocol=https;branch=v1.2.x"
16 S = "${WORKDIR}/git"
17
18 inherit autotools
19
20 BBCLASSEXTEND = "native"
21
22 # Fix copied from meta-tizen.
23 do_configure_prepend() {
24   export ac_cv_prog_DOXYGEN=""
25   sed -i 's@systemd_new=no@systemd_new=yes@' ${S}/configure.ac
26   sed -i '/PKG_CHECK_MODULES(/,/)/{s/b/r/p;d}' ${S}/configure.ac
27 }