3cbc3aea8cada8c9cd2959724d598be86e6635ee
[AGL/meta-agl.git] / meta-security / recipes-security / security-manager / security-manager_git.bb
1 require security-manager.inc
2
3 PV = "1.0.2+git${SRCPV}"
4 SRCREV = "860305a595d681d650024ad07b3b0977e1fcb0a6"
5 SRC_URI += "git://github.com/Samsung/security-manager.git"
6 S = "${WORKDIR}/git"
7
8 SRC_URI += " \
9 file://systemd-stop-using-compat-libs.patch \
10 file://security-manager-policy-reload-do-not-depend-on-GNU-.patch \
11 file://0001-Smack-rules-create-two-new-functions.patch \
12 file://0002-app-install-implement-multiple-set-of-smack-rules.patch \
13 file://c-11-replace-depracated-auto_ptr.patch \
14 file://socket-manager-removes-tizen-specific-call.patch \
15 file://Removing-tizen-platform-config.patch \
16 file://removes-dependency-to-libslp-db-utils.patch \
17 file://0001-Fix-gcc8-warning-error-Werror-catch-value.patch \
18 file://0001-Avoid-casting-from-const-T-to-void.patch \
19 "
20
21 ##########################################
22 # This are patches for backward compatibility to the version dizzy of poky.
23 # The dizzy version of libcap isn't providing a packconfig file.
24 # This is solved by the patch libcap-without-pkgconfig.patch.
25 # But after solving that issue, it appears that linux/xattr.h should
26 # also be include add definitions of XATTR_NAME_SMACK... values.
27 # Unfortunately, there is no explanation why linux/xattr.h should
28 # also be included (patch include-linux-xattr.patch)
29 ##########################################
30 do_patch[depends] = "libcap:do_populate_sysroot"
31 APPLY = "${@str('no' if os.path.exists('${STAGING_LIBDIR}/pkgconfig/libcap.pc') else 'yes')}"
32 SRC_URI += "\
33   file://libcap-without-pkgconfig.patch;apply=${APPLY} \
34   file://include-linux-xattr.patch;apply=${APPLY} \
35 "
36
37 # Use make with cmake and not ninja
38 OECMAKE_GENERATOR = "Unix Makefiles"