Add the nativesdk-cmake-apps-module-doc package to the SDK
[AGL/meta-agl.git] / meta-security / recipes-security / cynagora / cynagora-cynara-compat_2.1.bb
1 DESCRIPTION = "Cynara service with client libraries"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://Apache-2.0;md5=3b83ef96387f14655fc854ddc3c6bd57"
4
5 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/cynagora;protocol=https;branch=${AGL_BRANCH}"
6 SRCREV = "c84823f3981b56171482b41d2b704c32cdd8062a"
7 PV = "2.+git${SRCPV}"
8
9 S = "${WORKDIR}/git"
10
11 inherit cmake
12
13 PROVIDES = "cynara"
14 RPROVIDES_${PN} = "cynara"
15 DEPENDS = "libcap"
16 RDEPENDS_${PN} = "cynagora"
17
18 EXTRA_OECMAKE += " \
19         -DWITH_SYSTEMD=OFF \
20         -DWITH_CYNARA_COMPAT=ON \
21         -DDIRECT_CYNARA_COMPAT=ON \
22 "
23
24 do_install_append() {
25         # remove cynagora stuff
26         rm $(find ${D} -name '*cynagora*')
27         # remove stupid test
28         rm -r ${D}${bindir}
29 }
30