35dd361d41d842b51bc995f3bcbfc645d0b65156
[AGL/meta-agl.git] / meta-security / recipes-devtools / e2fsprogs / e2fsprogs_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 # Applying this patch is optional. Only some versions
4 # of e2fsprogs need it. So try to apply it, but if it fails,
5 # continue and hope the patch wasn't needed. If it is needed
6 # and got skipped, the oeqa Smack tests will catch the failure.
7 SRC_URI += "file://ext_attr.c-fix-adding-multiple-xattrs-during-image-c.patch;apply=no"
8
9 do_patch[postfuncs] += "patch_xattr_support"
10 patch_xattr_support () {
11     cd ${S}
12     cp lib/ext2fs/ext_attr.c lib/ext2fs/ext_attr.c.orig
13     patch lib/ext2fs/ext_attr.c <${WORKDIR}/ext_attr.c-fix-adding-multiple-xattrs-during-image-c.patch && rm lib/ext2fs/ext_attr.c.orig || mv lib/ext2fs/ext_attr.c.orig lib/ext2fs/ext_attr.c
14 }