pipewire: Update pw to v0.3.47 and wp to v0.4.8
[AGL/meta-agl.git] / meta-pipewire / recipes-multimedia / wireplumber / wireplumber_git.bb
1 SUMMARY     = "Session / Policy Manager for PipeWire"
2 HOMEPAGE    = "https://gitlab.freedesktop.org/pipewire/wireplumber"
3 BUGTRACKER  = "https://gitlab.freedesktop.org/pipewire/wireplumber/issues"
4 AUTHOR      = "George Kiagiadakis <george.kiagiadakis@collabora.com>"
5 SECTION     = "multimedia"
6
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
9
10 inherit meson pkgconfig systemd
11
12 DEPENDS = "glib-2.0 glib-2.0-native pipewire lua"
13
14 SRC_URI = "\
15     git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master \
16 "
17 # v0.4.8
18 SRCREV = "e14bb72dcc85e2130d0ea96768e5ae3b375a041e"
19
20 # patches to be able to compile with lower version of meson that is available in AGL.
21 SRC_URI += "\
22     file://0001-Revert-tests-add-pipewire-env-variables-when-running.patch \
23     file://0002-Revert-wp-uninstalled-build-this-script-with-the-mes.patch \
24     file://0003-spa-json-fix-va_list-APIs-for-different-architecture.patch \
25 "
26
27 PV = "0.4.8"
28 S  = "${WORKDIR}/git"
29
30 WPAPI="0.4"
31
32 # use shared lua from the system instead of the static bundled one
33 EXTRA_OEMESON += "-Dsystem-lua=true"
34
35 # introspection in practice is only used for generating API docs
36 # API docs are available on the website and we don't need to build them
37 # (plus they depend on hotdoc which is not available here)
38 EXTRA_OEMESON += "-Dintrospection=disabled -Ddoc=disabled"
39
40 PACKAGECONFIG = "\
41     ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
42 "
43
44 PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsystemd-system-service=true -Dsystemd-user-service=false,-Dsystemd=disabled -Dsystemd-system-service=false -Dsystemd-user-service=false,systemd"
45
46 do_configure:prepend() {
47     # relax meson version requirement
48     # we only need 0.54 when building with -Dsystem-lua=false
49     sed "s/meson_version : '>= 0.56.0'/meson_version : '>= 0.53.2'/" ${S}/meson.build > ${S}/tmp.build
50     mv -f ${S}/tmp.build ${S}/meson.build
51 }
52
53 PACKAGES =+ "\
54     lib${PN}-${WPAPI} \
55     ${PN}-config \
56 "
57
58 SYSTEMD_SERVICE:${PN} = "wireplumber.service"
59 FILES:${PN} = "\
60     ${bindir}/wireplumber \
61     ${bindir}/wpctl \
62     ${bindir}/wpexec \
63     ${libdir}/wireplumber-${WPAPI}/* \
64     ${datadir}/wireplumber/scripts/* \
65     ${systemd_system_unitdir}/* \
66 "
67 RPROVIDES:${PN} += "virtual/pipewire-sessionmanager"
68 RDEPENDS:${PN} += "virtual/wireplumber-config"
69
70 FILES:lib${PN}-${WPAPI} = "\
71     ${libdir}/libwireplumber-${WPAPI}.so.* \
72 "
73
74 FILES:${PN}-config += "\
75     ${sysconfdir}/wireplumber/* \
76     ${datadir}/wireplumber/*conf \
77     ${datadir}/wireplumber/common/* \
78     ${datadir}/wireplumber/main.lua.d/* \
79     ${datadir}/wireplumber/bluetooth.lua.d/* \
80     ${datadir}/wireplumber/policy.lua.d/* \
81 "
82 CONFFILES:${PN}-config += "\
83     ${sysconfdir}/wireplumber/* \
84 "
85 RPROVIDES:${PN}-config += "virtual/wireplumber-config"