wireplumber: Add Equalizer filter chain node
[AGL/meta-agl.git] / meta-pipewire / recipes-multimedia / wireplumber / wireplumber_git.bb
1 SUMMARY     = "Session / Policy Manager for PipeWire"
2 HOMEPAGE    = "https://gitlab.freedesktop.org/pipewire/wireplumber"
3 BUGTRACKER  = "https://gitlab.freedesktop.org/pipewire/wireplumber/issues"
4 AUTHOR      = "George Kiagiadakis <george.kiagiadakis@collabora.com>"
5 SECTION     = "multimedia"
6
7 LICENSE = "MIT"
8 LIC_FILES_CHKSUM = "file://LICENSE;beginline=3;md5=e8ad01a5182f2c1b3a2640e9ea268264"
9
10 inherit meson pkgconfig systemd
11
12 DEPENDS = "glib-2.0 glib-2.0-native pipewire lua"
13
14 SRC_URI = "\
15     git://gitlab.freedesktop.org/pipewire/wireplumber.git;protocol=https;branch=master \
16     file://0001-policy-endpoint-device.lua-fix-dangling-logs-issue.patch \
17 "
18 # v0.4.16
19 SRCREV = "0d249b8a13d7168fe54fa6eb1db1c4a5fcc8d3f8"
20
21 # patches to be able to compile with lower version of meson that is available in AGL.
22 SRC_URI += "\
23 "
24
25 PV = "0.4.16"
26 S  = "${WORKDIR}/git"
27
28 WPAPI="0.4"
29
30 # use shared lua from the system instead of the static bundled one
31 EXTRA_OEMESON += "-Dsystem-lua=true"
32
33 # introspection in practice is only used for generating API docs
34 # API docs are available on the website and we don't need to build them
35 # (plus they depend on hotdoc which is not available here)
36 EXTRA_OEMESON += "-Dintrospection=disabled -Ddoc=disabled"
37
38 PACKAGECONFIG = "\
39     ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
40 "
41
42 PACKAGECONFIG[systemd] = "-Dsystemd=enabled -Dsystemd-system-service=true -Dsystemd-user-service=false,-Dsystemd=disabled -Dsystemd-system-service=false -Dsystemd-user-service=false,systemd"
43
44 do_configure:prepend() {
45     # relax meson version requirement
46     # we only need 0.54 when building with -Dsystem-lua=false
47     sed "s/meson_version : '>= 0.56.0'/meson_version : '>= 0.53.2'/" ${S}/meson.build > ${S}/tmp.build
48     mv -f ${S}/tmp.build ${S}/meson.build
49 }
50
51 PACKAGES =+ "\
52     lib${PN}-${WPAPI} \
53     ${PN}-config \
54 "
55
56 SYSTEMD_SERVICE:${PN} = "wireplumber.service"
57 FILES:${PN} = "\
58     ${bindir}/wireplumber \
59     ${bindir}/wpctl \
60     ${bindir}/wpexec \
61     ${libdir}/wireplumber-${WPAPI}/* \
62     ${datadir}/wireplumber/scripts/* \
63     ${datadir}/zsh/* \
64     ${systemd_system_unitdir}/* \
65 "
66 RPROVIDES:${PN} += "virtual/pipewire-sessionmanager"
67
68 FILES:lib${PN}-${WPAPI} = "\
69     ${libdir}/libwireplumber-${WPAPI}.so.* \
70 "
71
72 FILES:${PN}-config += "\
73     ${sysconfdir}/wireplumber/* \
74     ${datadir}/wireplumber/*conf \
75     ${datadir}/wireplumber/common/* \
76     ${datadir}/wireplumber/main.lua.d/* \
77     ${datadir}/wireplumber/bluetooth.lua.d/* \
78     ${datadir}/wireplumber/policy.lua.d/* \
79 "
80 do_install:append() {
81     rm -rf ${D}${sysconfdir}/wireplumber/
82     rm -f ${D}${datadir}/wireplumber/*conf
83     rm -rf ${D}${datadir}/wireplumber/common
84     rm -rf ${D}${datadir}/wireplumber/main.lua.d
85     rm -rf ${D}${datadir}/wireplumber/bluetooth.lua.d
86     rm -rf ${D}${datadir}/wireplumber/policy.lua.d
87 }