pipewire: Add user session socket activation
[AGL/meta-agl-devel.git] / meta-pipewire / recipes-multimedia / pipewire / pipewire_git.bbappend
1 do_install_append() {
2     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
3         # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
4         # because it does not support systemd's user mode.
5         mkdir -p ${D}${sysconfdir}/systemd/user/sockets.target.wants/
6         ln -sf ${systemd_user_unitdir}/pipewire.socket ${D}${sysconfdir}/systemd/user/sockets.target.wants/pipewire.socket
7     fi
8 }
9
10 FILES_${PN} += "${sysconfdir}/systemd/user/"
11