meta-agl-flutter: add agl-flutter-env
[AGL/meta-agl-devel.git] / meta-offline-voice-agent / recipes-python / python3-vosk-websocket-server / python3-vosk-websocket-server_git.bb
1 DESCRIPTION = "WebSocket, gRPC and WebRTC speech recognition server based on Vosk and Kaldi libraries"
2 SUMMARY = "This is a server for highly accurate offline speech recognition using Kaldi and Vosk-API."
3 HOMEPAGE = "https://github.com/alphacep/vosk-server"
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=d09bbd7a3746b6052fbd78b26a87396b"
6
7 SRC_URI = "git://github.com/alphacep/vosk-server;protocol=https;branch=master"
8
9 PV = "1.0+git${SRCPV}"
10 SRCREV = "70f3d5321a40f2f5dffe9c833bc1fac4b3b451e7"
11
12 S = "${WORKDIR}/git"
13
14 RDEPENDS:${PN} += " \
15     vosk \
16     python3-vosk-api \
17     python3-websockets \
18     virtual/vosk-model \
19 "
20
21 do_configure () {
22         :
23 }
24
25 do_compile () {
26         :
27 }
28
29 do_install () {
30         install -d ${D}${bindir}
31         cp ${S}/websocket/asr_server.py ${D}${bindir}/vosk-websocket-python.py
32     chmod a+x ${D}${bindir}/vosk-websocket-python.py
33 }