[wam][cef] Add the agl-cef feature to use cef as a wam backend
[AGL/meta-agl-devel.git] / meta-offline-voice-agent / recipes-python / python3-sounddevice / python3-sounddevice_0.4.4.bb
1 SUMMARY = "Play and Record Sound with Python"
2 HOMEPAGE = "http://python-sounddevice.readthedocs.io/"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=bd8634ff9bb1159041c3d4328659d00f"
5
6 SRC_URI = "gitsm://github.com/spatialaudio/python-sounddevice;protocol=https;branch=master"
7
8 PV = "0.4.4+git${SRCPV}"
9 SRCREV = "a56cdb96c9c8e3d23b877bbcc7d26bd0cda231e0"
10
11 S = "${WORKDIR}/git"
12
13 inherit setuptools3
14
15 # PACKAGECONFIG ?= "numpy"
16 PACKAGECONFIG[numpy] = "python3-numpy"
17
18 DEPENDS += "python3-cffi-native"
19
20 RDEPENDS:${PN} += "portaudio-v19 python3-cffi python3-core python3-ctypes python3-numpy"