Add dependencies for intent engine snips
[AGL/meta-agl-devel.git] / meta-offline-voice-agent / recipes-nlu / nlu-model / snips-model-agl_0.2.0.bb
1 SUMMARY = "Dataset and a pre-trained model for the Automotive Grade Linux's Snips NLU intent engine."
2 HOMEPAGE = "https://github.com/malik727/snips-model-agl"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=ecab3ce0771d366e0f8e4ca058eb48e7"
5
6 SRC_URI = " \
7     git://github.com/malik727/snips-model-agl.git;protocol=https;branch=main \
8 "
9
10 PV = "1.0.0+git${SRCPV}"
11 SRCREV = "${AUTOREV}"
12 S = "${WORKDIR}/git"
13
14 do_install() {
15     install -d ${D}/usr/share/nlu/snips
16     cp -R ${WORKDIR}/git/* ${D}/usr/share/nlu/snips/
17 }
18
19 FILES:${PN} += " /usr/share/nlu/snips"