Convert to new override syntax
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-support / os-rpclibrary / os-rpclibrary-tool_1.0.0.bb
1 SUMMARY = "librpc tools for AGL software"
2 DESCRIPTION = "install librpc tool"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://../LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6 DEPENDS += " \
7     agl-basefiles-native \
8     bison-native \
9 "
10
11 PV = "1.0.0+gitr${SRCPV}"
12 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
13 SRCREV := "${BASESYSTEM_REVISION}"
14
15 S = "${WORKDIR}/git/service/other/rpc_library/tool"
16
17 do_compile:prepend () {
18     oe_runmake clean
19 }
20
21 do_install () {
22     install -D -m 755 ${S}/rpc_apidef ${D}${bindir}/rpc_apidef
23 }
24
25 FILES:${PN} += " \
26     ${bindir}/rpc_apidef \
27 "
28
29 BBCLASSEXTEND = "native"