oem-pr-bs: add various HAL libraries
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-hal / libpower-hal / libpower-hal_1.0.0.bb
1 SUMMARY = "libpower_hal for AGL software"
2 DESCRIPTION = "install libpower_hal to build AGL software"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6 DEPENDS += " ns-frameworkunified"
7
8 PV = "1.0.0+gitr${SRCPV}"
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV := "${BASESYSTEM_REVISION}"
11
12 S = "${WORKDIR}/git/hal/power_hal"
13
14 inherit bshalmake
15
16 HAL_NAME = "power_hal"
17 FILES_${PN} += "${libdir}/lib${HAL_NAME}.so"