b28c0178ad71af41691e912eb6cb816901c88f80
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-devtools / perl / libpath-tiny-perl_0.114.bb
1 SUMMARY = "Path::Tiny - File path utility"
2 DESCRIPTION = "This module provides a small, fast utility for working with \
3 file paths. It is friendlier to use than File::Spec and provides easy access \
4 to functions from several other core file handling modules"
5 HOMEPAGE = "https://github.com/dagolden/Path-Tiny"
6 SECTION = "libs"
7 LICENSE = "Apache-2.0"
8
9 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
10
11 SRC_URI = "https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Path-Tiny-${PV}.tar.gz"
12 SRC_URI[sha256sum] = "cd0f88f37a58fc3667ec065767fe01e73ee6efa18a112bfd3508cf6579ca00e1"
13
14 S = "${WORKDIR}/Path-Tiny-${PV}"
15
16 inherit cpan ptest-perl
17
18 RDEPENDS:${PN} += " \
19     perl-module-file-spec \
20     perl-module-file-temp \
21     perl-module-test-more \
22 "
23
24 BBCLASSEXTEND = "native"