oem-pr-bs: add core services and libraries
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-core / ns-frameworkunified / ns-frameworkunified_1.0.0.bb
1 SUMMARY = "ns-frameworkunified for AGL software"
2 DESCRIPTION = "ns-frameworkunified to build AGL software"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6 DEPENDS += " \
7     os-posixbasedos001legacylibrary \
8     ns-loglibrary \
9     ns-commonlibrary \
10     boost \
11 "
12
13 PV = "1.0.0+gitr${SRCPV}"
14 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
15 SRCREV := "${BASESYSTEM_REVISION}"
16
17 S = "${WORKDIR}/git/service/native/framework_unified"
18
19 inherit agl-basesystem-common
20
21 BSMAKE_FILE = "Makefile.client"
22
23 FILES_${PN} += " \
24     ${libdir}/* \
25 "
26
27 RDEPENDS_${PN} += " \
28     os-posixbasedos001legacylibrary \
29     ns-loglibrary \
30     ns-commonlibrary \
31     ns-frameworkunified-library \
32 "