oem-pr-bs: add positioning service
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-core / ns-frameworkunified / ns-frameworkunified-library_1.0.0.bb
1 SUMMARY = "ns-frameworkunified library for AGL software"
2 DESCRIPTION = "ns-frameworkunified library to build AGL software"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6 DEPENDS += " \
7     ns-loglibrary \
8     libxml2 \
9     ns-frameworkunified \
10 "
11
12 PV = "1.0.0+gitr${SRCPV}"
13 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
14 SRCREV := "${BASESYSTEM_REVISION}"
15
16 S = "${WORKDIR}/git/service/native/framework_unified"
17
18 inherit agl-basesystem-common
19
20 BSMAKE_FILE = "Makefile.library"
21
22 RDEPENDS_${PN} += " \
23     os-posixbasedos001legacylibrary \
24     ns-loglibrary \
25     ns-commonlibrary \
26 "