meta-agl-devel: remove meta-agl-wireless-monitor
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-core / agl-systemd / agl-systemd_1.0.0.bb
1 SUMMARY = "Systemd related file for launching sample application"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
4
5 PV = "1.0.0+gitr${SRCPV}"
6 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
7 SRCREV := "${BASESYSTEM_REVISION}"
8
9 S = "${WORKDIR}/git/agl-systemd"
10
11 inherit systemd
12
13 do_configure[noexec] = "1"
14 do_compile[noexec] = "1"
15
16 do_install() {
17     install -d ${D}${sysconfdir}/systemd/system/
18     install -m 644 ${S}/launch_sm.service ${D}${sysconfdir}/systemd/system/
19     install -m 644 ${S}/systemd-udev-trigger.service ${D}${sysconfdir}/systemd/system/
20     install -m 644 ${S}/setup_refhw.service ${D}${sysconfdir}/systemd/system/
21
22     install -d ${D}${CONFDIR}/
23     install -m 644 ${S}/env.txt ${D}${CONFDIR}/
24
25     install -d ${D}${bindir}
26     install -m 755 ${S}/tool_9E_SI/*.sh ${D}${bindir}/
27
28     install -d ${D}${libdir}/udev/rules.d
29     install -m 644 ${S}/99-basesystem.rules ${D}/${libdir}/udev/rules.d/
30 }
31
32 RDEPENDS:${PN} += "bash"
33
34 SYSTEMD_SERVICE:${PN} = " \
35     launch_sm.service \
36     systemd-udev-trigger.service \
37     setup_refhw.service \
38 "