meta-agl-devel: remove meta-agl-wireless-monitor
[AGL/meta-agl-devel.git] / meta-oem-production-readiness / meta-agl-basesystem / recipes-apis / agl-service-ps-communication / agl-service-ps-communication_1.0.0.bb
1 SUMMARY = "agl-service-ps-communication for AGL software"
2 DESCRIPTION = "agl-service-ps-communication to build AGL software"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
5
6 DEPENDS += " \
7     ns-frameworkunified \
8     ps-communication \
9     os-posixbasedos001legacylibrary \
10     ss-interfaceunified \
11     ss-romaccesslibrary \
12     libcan-hal \
13 "
14
15 PV = "1.0.0+gitr${SRCPV}"
16 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
17 SRCREV := "${BASESYSTEM_REVISION}"
18
19 S = "${WORKDIR}/git/service/peripheral/communication"
20
21 inherit agl-basesystem-common
22
23 BSMAKE_FILE = "Makefile.server"
24
25 RDEPENDS:${PN} += " \
26     ns-frameworkunified \
27     ps-communication \
28     os-posixbasedos001legacylibrary \
29     ss-interfaceunified \
30     ss-romaccesslibrary \
31     libcan-hal \
32 "