Add software packages for oem needs library
[AGL/meta-agl-devel.git] / meta-oem-extra-libs / recipes-core / libtar / libtar_1.2.20.bb
1 SUMMARY = "libtar, tar manipulating library"
2 DESCRIPTION = "libtar is a library for manipulating POSIX tar files"
3 HOMEPAGE = "http://www.feep.net/libtar"
4 SECTION = "libs"
5 LICENSE = "NCSA"
6 LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=61cbac6719ae682ce6cd45b5c11e21af"
7
8 # Source and patches taken from debian check there for changes.
9 # Check http://repo.or.cz/w/libtar.git/ as upstream.
10 # More patches found here: https://github.com/tklauser/libtar
11 #
12 SRC_URI  = "http://httpredir.debian.org/debian/pool/main/libt/libtar/libtar_${PV}.orig.tar.gz"
13 SRC_URI += "file://no_static_buffers.patch"
14 SRC_URI += "file://no_maxpathlen.patch"
15 SRC_URI += "file://CVE-2013-4420.patch"
16 SRC_URI += "file://th_get_size-unsigned-int.patch"
17 SRC_URI += "file://oldgnu_prefix.patch"
18 SRC_URI += "file://testsuite.patch"
19 SRC_URI += "file://no_strip.patch"
20
21 SRC_URI[md5sum] = "6ced95ab3a4b33fbfe2dfb231d156cdb"
22 SRC_URI[sha256sum] = "50f24c857a7ef1cb092e6508758b86d06f1188508f897f3e6b40c573e8879109"
23
24 # tarball does not contain PV
25 S = "${WORKDIR}/${PN}"
26
27 CFLAGS_append  = " -DHAVE_STDARG_H"
28
29 RDEPENDS_${PN} += "zlib"
30
31 inherit autotools