meta-netboot: Add SELinux support
[AGL/meta-agl.git] / meta-netboot / recipes-core / systemd / resolv-conf-relabel.bb
1 SUMMARY     = "System unit to relabel resolve.conf"
2 LICENSE     = "MIT"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5 SRC_URI = "file://resolv-conf-relabel.service"
6
7 inherit systemd allarch features_check
8
9 SYSTEMD_SERVICE:${PN} = "${BPN}.service"
10
11 REQUIRED_DISTRO_FEATURES = "systemd"
12
13 do_configure[noexec] = "1"
14 do_compile[noexec] = "1"
15
16 do_install() {
17     install -d ${D}${systemd_system_unitdir}
18     install -m 0644 ${WORKDIR}/resolv-conf-relabel.service ${D}${systemd_system_unitdir}/
19 }
20
21 FILES:${PN} += "${systemd_system_unitdir}"