363e6bcc9518b5fa0ee843f2d634d90a6a387e14
[AGL/meta-agl.git] / meta-netboot / classes / netboot.bbclass
1 # Enable network bootable image and initrd/initramfs
2
3 python () {
4         if (bb.utils.contains_any("IMAGE_FSTYPES",["live","wic.vmdk"],True,False,d)):
5                 # typical case for Minnowboard Max
6                 d.setVar("INITRD_IMAGE","initramfs-netboot-image")
7                 d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))
8                 d.setVar("INITRD_LIVE","%s/%s-%s.ext4.gz" % (
9                         d.getVar("DEPLOY_DIR_IMAGE",True),
10                         d.getVar("INITRD_IMAGE_LIVE",True),
11                         d.getVar("MACHINE",True)
12                 ))
13         else:
14                 d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
15                 if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
16                         # case for "old" u-boot images, like Porter board
17                         d.setVar("NETBOOT_FSTYPES", "ext4.gz.u-boot");
18                 else:
19                         # case for new u-boot images which don't require uImage format 
20                         d.setVar("NETBOOT_FSTYPES", "ext4.gz");
21 }
22