Merge "af-main: Refactor of user session management"
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     ipv6connect \
25     linpack \
26     linus-stress \
27     lmbench \
28     ltp \
29     nbench-byte \
30     packagegroup-ivi-common-test-ltp \
31     rt-tests \
32     stress \
33     "
34 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
35 #    netperf
36
37 # FTBS, SPEC-316
38 #    himeno 
39 # FTBS, SPEC-1384
40 #    trinity
41
42
43 # Packages for shell commands which are required by LTP
44 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
45 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
46 #   pgrep
47 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
48     initscripts-functions bind-utils binutils \
49     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
50     iptables logrotate net-tools sysstat tcpdump vsftpd \
51     "