Remove deprecated package netpipe
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     ipv6connect \
25     linpack \
26     linus-stress \
27     lmbench \
28     ltp \
29     nbench-byte \
30     packagegroup-ivi-common-test-ltp \
31     rt-tests \
32     stress \
33     trinity \
34     "
35 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
36 #    netperf
37 # wayland-fits is broken in jethro, https://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg46505.html
38 # http://errors.yoctoproject.org/Errors/Details/35141/
39 #     wayland-fits
40
41 # FTBS, SPEC-316
42 #    himeno 
43
44
45 # Packages for shell commands which are required by LTP
46 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
47 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
48 #   pgrep
49 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
50     initscripts-functions bind-utils binutils \
51     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
52     iptables logrotate net-tools sysstat tcpdump vsftpd \
53     "