3de0d4b09bda2f24d3e3914e4ba4047bbedbef55
[AGL/meta-agl.git] / meta-ivi-common / recipes-test / packagegroups / packagegroup-ivi-common-test.bb
1 SUMMARY = "Utilities for testing of AGL"
2 DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-ivi-common-test \
10     packagegroup-ivi-common-test-ltp \
11     "
12
13 ALLOW_EMPTY_${PN} = "1"
14
15 RDEPENDS_${PN} += "\
16     bc \
17     blobsallad \
18     dbench \
19     ebizzy \
20     ffsb \
21     interbench \
22     iozone3 \
23     iperf \
24     ipv6connect \
25     linpack \
26     linus-stress \
27     lmbench \
28     ltp \
29     nbench-byte \
30     netpipe \
31     packagegroup-ivi-common-test-ltp \
32     rt-tests \
33     stress \
34     trinity \
35     "
36 # to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
37 #    netperf
38 # wayland-fits is broken in jethro, https://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg46505.html
39 # http://errors.yoctoproject.org/Errors/Details/35141/
40 #     wayland-fits
41
42 # FTBS, SPEC-316
43 #    himeno 
44
45
46 # Packages for shell commands which are required by LTP
47 #   readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
48 #   host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
49 #   pgrep
50 RDEPENDS_packagegroup-ivi-common-test-ltp += " \
51     initscripts-functions bind-utils binutils \
52     cronie dnsmasq expect inetutils-ftp inetutils-rsh \
53     iptables logrotate net-tools sysstat tcpdump vsftpd \
54     "