Changes for building with YP 2.1.1 'krogoth'
[AGL/meta-agl.git] / meta-ivi-common / recipes-graphics / wayland / wayland-ivi-extension_1.9.1.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=176cedb32f48dd58f07e0c1c717b3ea4"
7
8 DEPENDS = "weston"
9
10 SRC_URI = "git://github.com/GENIVI/${PN}.git;protocol=https \
11           "
12 SRC_URI_append_wandboard = "file://wandboard_fix_build.patch"
13
14 SRCREV = "44598504503eea5ac7f94c88477a5a78bda01f30"
15
16 S = "${WORKDIR}/git"
17
18 inherit cmake
19 #jsmoeller: rm autotools from inherit ... there can only be one
20
21 PACKAGECONFIG ??= "ilm_input"
22 PACKAGECONFIG[ivi-share] = "-DIVI_SHARE=ON,-DIVI_SHARE=OFF,libgbm libdrm"
23 PACKAGECONFIG[ilm_input] = "-DWITH_ILM_INPUT=1,-DWITH_ILM_INPUT=0"
24
25 FILES_${PN} += "${libdir}/weston/*"
26 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"