e20132cabe62d87afb2bc4c7dd167413c588a49f
[AGL/meta-agl.git] / meta-ivi-common / recipes-graphics / wayland / wayland-ivi-extension_1.13.0.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "ede33c1c898eeaf673dd2c275e92763a5aabd066"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
10         file://0001-simple-id-agent-initial-commit.patch;patch=1 \
11         file://0002-ivi-controller-load-id-agent-module.patch;patch=1 \
12         file://0003-ivi-controller-add-resize-setting-suit-to-surface-si.patch \
13 "
14 S = "${WORKDIR}/git"
15
16 DEPENDS = "weston virtual/libgles2 pixman wayland-native"
17
18 inherit cmake
19
20 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
21
22 FILES_${PN} += "${libdir}/weston/*"
23 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
24
25 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
26
27 FILESEXTRAPATHS_prepend := ":${THISDIR}/wayland-ivi-extension:"
28
29 SRC_URI_append_wandboard = " file://wandboard_fix_build.patch"
30
31 # workaround paralellism issue:
32 PARALLEL_MAKE = ""