581cc5b1330fa3a01ce1abb074059559471c50c4
[AGL/meta-agl.git] / meta-ivi-common / recipes-graphics / wayland / wayland-ivi-extension_1.11.0.bb
1 SUMMARY = "Wayland IVI Extension"
2 DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
3 HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
4 BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
7
8 SRCREV = "c9001582b10ce209c37b42dd560947c5aa8928b3"
9 SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
10     "
11 S = "${WORKDIR}/git"
12
13 DEPENDS = "weston virtual/libgles2 pixman"
14
15 inherit cmake
16
17 EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
18
19 FILES_${PN} += "${libdir}/weston/*"
20 FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
21
22 EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"