Changes for building with YP 2.1.1 'krogoth'
[AGL/meta-agl.git] / meta-ivi-common / recipes-extended / dlt-daemon / dlt-daemon_2.15.0.bb
1 SUMMARY = "Diagnostic Log and Trace"
2 DESCRIPTION = "This component provides a standardised log and trace interface, \
3 based on the standardised protocol specified in the AUTOSAR standard 4.0 DLT. \
4 This component can be used by GENIVI components and other applications as \
5 logging facility providing: \
6 - the DLT shared library \
7 - the DLT daemon, including startup scripts \
8 - the DLT daemon adaptors- the DLT client console utilities \
9 - the DLT test applications"
10 HOMEPAGE = "https://www.genivi.org/"
11 SECTION = "console/utils"
12 LICENSE = "MPLv2"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=8184208060df880fe3137b93eb88aeea"
14
15 DEPENDS = "dbus zlib"
16
17 SRCREV = "e9a486a08fff6d3cc7133a350cec3ee10f463207"
18 SRC_URI = "git://git.projects.genivi.org/${BPN}.git;protocol=http \
19     file://0002-Don-t-execute-processes-as-a-specific-user.patch \
20     file://0004-Modify-systemd-config-directory.patch \
21     "
22 S = "${WORKDIR}/git"
23
24 inherit gzipnative autotools gettext cmake systemd
25
26 PACKAGES += "${PN}-systemd"
27 SYSTEMD_PACKAGES = "${PN} ${PN}-systemd"
28 SYSTEMD_SERVICE_${PN} = "dlt-system.service dlt.service"
29 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
30 SYSTEMD_SERVICE_${PN}-systemd = "dlt-example-user.service \
31     dlt-dbus.service \
32     dlt-adaptor-udp.service \
33     dlt-receive.service"
34 SYSTEMD_AUTO_ENABLE_${PN}-systemd = "disable"
35
36 EXTRA_OECMAKE = "-DWITH_SYSTEMD=ON"
37
38 FILES_${PN}-doc += "/usr/share/dlt-filetransfer"
39
40 do_install_append() {
41    rm -f ${D}${bindir}/dlt-test-*
42 }