meta-html5-framework/wam: adjust how wam is started
[AGL/meta-agl-devel.git] / meta-html5-framework / recipes-wam / wam / wam_git.bb
1 SUMMARY = "WAM"
2 AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6 inherit cmake
7
8 DEPENDS = "glib-2.0 jsoncpp boost chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
9
10 EXTRA_OECMAKE = "\
11     -DCMAKE_BUILD_TYPE=Release \
12     -DCMAKE_INSTALL_PREFIX=${prefix} \
13     -DPLATFORM_NAME=${@'${DISTRO}'.upper().replace('-', '_')} \
14     -DCHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
15
16 PR="r0"
17
18 PROVIDES += "virtual/webruntime"
19 RPROVIDES_${PN} += "virtual/webruntime"
20
21 SRC_URI = "\
22     git://github.com/webosose/${PN}.git;branch=@6.agl.guppy;protocol=https \
23     file://WebAppMgr@.service \
24     file://WebAppMgr.env \
25 "
26 S = "${WORKDIR}/git"
27 SRCREV = "8271e13578b92b192cef1d1ac6577bc3699518a4"
28
29 do_install_append() {
30     install -d ${D}${sysconfdir}/wam
31     install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
32     install -d ${D}${systemd_system_unitdir}
33     install -v -m 644 ${WORKDIR}/WebAppMgr@.service ${D}${systemd_system_unitdir}/WebAppMgr@.service
34     install -d ${D}${sysconfdir}/default/
35     install -v -m 644 ${WORKDIR}/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
36     ln -snf WebAppMgr ${D}${bindir}/web-runtime
37     install -d ${D}${systemd_system_unitdir}/afm-user-session@.target.wants
38     ln -sf ../WebAppMgr@.service ${D}${systemd_system_unitdir}/afm-user-session@.target.wants/
39 }
40
41 RDEPENDS_${PN} += "wam-tinyproxy"
42 FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_system_unitdir}"
43
44 CXXFLAGS_append_agl-devel = " -DAGL_DEVEL"